手贱的服务器管理员

手贱

一般负责服务器维护的人,都不会让服务器里的Apache或者PHP版本紧跟着官方发布的走,但是,手贱的版本党肯定是要更新的,比如我。结果就是呢,Apache和PHP与服务器里的各种程序不兼容,比如Joomla和Wordpress。

Joomla从3.7版本开始,一直和PHP 7.1.X不和,表现为featured articles没法排序,这问题在我这里已经快两个月了吧。Joomla目前已经更新到了3.7.3,但是问题依旧,解决办法也不是没有,把PHP降级到7.0.x,版本党怎么能忍?

Wordpress这边,自从Apache跟新到了2.4.26之后,后台连文章列表都打不开,错误提示:Invalid post type. 原因是Apache 2.4.26之后添加了一个ProxyFCGIBackendType的设置,默认值是FPM,如果设置成GENERIC的话,Wordpress这边倒是不会报错,但是:

This variable is what some generic FastCGI applications would read as their script input, but PHP-FPM would strip the prefix then remember it was talking to Apache. In 2.4.21 through 2.4.25, this prefix was automatically stripped by the server, breaking the ability of PHP-FPM to detect and interoperate with Apache in some scenarios.(翻译过来的意思就是——强迫症患者就是不爽!)

而且手贱的服务器管理员近期还有一个计划,把服务器操作系统从Centos 7换成openSUSE Leap 42.3(截止发稿前,Leap 42.3还有两天才发布),一颗赛艇!

LAMP

Email: i at onepx dot com || QQ: ⑧九零三④幺 || 微信: onepxcom
©2019 一像素 蜀ICP备13026576号-2 技术支持:成都网站建设