LAMP

标签——LAMP,即Linux+Apache+Mysql+PHP,我的LAMP操作笔记。

卡巴斯基浏览器插件和http header content-encoding: gzip

很早之前,我就通过 apache 的 mod_deflate 开启了网站的 gzip 传输,然后就没再管了,当然,这玩意儿开着谁也不会去管,几年过去了……直到今天,我在调试一个网站插件的时候,通过 Firefox web developer 突然发现——我的网站居然不支持 gzip 传输了!

opensuse从15.0升级到15.1后,ssh连接不上的解决办法

opensuse 15.1正式发布以后,我马上就对两台服务器进行了升级,不得不说我的心脏真的很大。升级的过程很简单,把/etc/zypp/repos.d里面所有源的链接从15.0换成15.1就可以zypper dup了。重启之后发现,所有apache+php-fpm+mariadb+firewalld...等等工作正常,就是ssh连不上服务器了,putty提示:

openSUSE Leap 42.3 的 apache+mariadb+php-fpm 安装笔记

近期部署了一台系统为 opensuse leap 42.3 的服务器,这是我在服务器上第一次使用 opensuse 作为系统,目前已经正常服役十多天,稳如狗。我之前的服务器系统一直是 centos ,对它最主要的不满是其官方的 lamp 版本实在太低,很多时候我都是手工编译升级,但是编译的最新版呢又经常和现有程序不合拍,见——手贱的服务器管理员,日久不爱。因此我需要一个自带 lamp 版本比较新,但是又不能太新的 linux 发新版做服务器系统。于是,我想起了我的老情人,openSUSE!

手贱的服务器管理员

一般负责服务器维护的人,都不会让服务器里的Apache或者PHP版本紧跟着官方发布的走,但是,手贱的版本党肯定是要更新的,比如我。结果就是呢,Apache和PHP与服务器里的各种程序不兼容,比如Joomla和Wordpress。

php-fpm中的request_terminate_timeout最好不要设置

刚转到php-fpm没几天就发现,进入我的joomla后台,firefox偶尔会给我白屏的那种http 503,这种情况仅出现在天翼云的服务器上,而我在国外的同样配置的服务器一点问题都没有,后来发现是request_terminate_timeout的问题。

从apache mod_php到php-fpm

很多文章说mod_php不能和apache mpm worker或者event共用,这也许是在apache 2.2版本时代流传下来的说法。自去年编译apache 2.4以来,我就一直在使用mpm event,而且根据我编译php 5.5的参数来看,我就是把php做为apache的一个内置模块。这样奇葩的配置存在一年多以后,我终于决定从mod_php过渡到php-fpm。

Centos 7 编译安装 Mariadb 10

最近刚上线了一台centos 7服务器,系统自带的mariadb版本仍停留在5.5系列,该系列的innodb引擎依然不支持full-text,既全文索引,支持full-text的版本是10系列。目前mariadb官方还没有为centos 7打rpm包,而另一个已打包mariadb 10系列的著名源——俄罗斯的centalt,却已经403 forbidden很久了...

Putty颜色设置

用了这么几年的putty,直到今天才知道putty是可以设置颜色的...悲催的被putty高对比度的黑白亮瞎了几年眼睛,保存一个颜色方案上来,免得重装系统丢失配置:

Centos编译安装Apache 2.4.6笔记

之前服务器 Apache 版本一直是 2.2.x,鉴于 Centos 更新软件的惰性,我看直到 2014 年结束,apache 2.4 都不一定会出现在 Centos 中,我是不打算等了,编译安装吧。

升级到 PHP 5.5.x + opcache

前几天看新闻说 php 5.5.3 发布了,还捆绑之前的 Zend Optimizer+ (现在叫 OPcache) 我就去我的服务器里看了看,PHP 5.3.26....纳尼!作为版本控,效率控,这是绝对不能允许的。

Mysql ERROR 1045 (28000)

昨天yum update更新了一票东西,今天用mysql -u root -p登录mysql的时候居然出现ERROR 1045 (28000):

Linode Centos6 64位安装配置LAMP

这是我在Linode的VPS上,安装配置LAMP的过程。基础Linux系统Centos6 64bit;内存756MB;Intel(R) Xeon(R) L5520 @ 2.27GHz,4核心,理论上会有30个VPS分享这颗CPU -_-!。

Apache限制多线程下载

服务器上共享了一部连载漫画,刚开始发现迅雷的盗链下载很厉害,就用 .htaccess 屏蔽了迅雷下载。而后来下载的人越来越多,其它多线程下载软件的威力也不容小视,Apache 平均每秒钟就要新开 3 个线程,遇到集群下载,还真有点吃不消。

让cPanel的phpMyAdmin支持.zip导入

之前在 Knownhost 的 VPS 用 cPanel,也用过 DirectAdmin,这两种面板里 phpMyAdmin 在导入 SQL 数据的时候,都支持上传 .zip 附件:

美化Index of /目录列表页面

出于安全考虑,多数 apache 服务器都不允许访问不带 index.html 的目录。如果确实有需要,我们可以在该目录下建立 .htaccess 文件,内容如下:

Wordpress http 404, mod_rewrite和系统负载

相信很多Wordpress用户都打开了mod_rewrite功能,这对访问者或者搜索引擎来说是一个非常友好的设置,但也可能给服务器带来意想不到的高系统负载。比如,当下面的这种垃圾集群试的访问服务器的时候:

Email: i at onepx dot com || QQ: ⑧九零三④幺 || 微信: onepxcom
©2019 一像素 蜀ICP备13026576号-2 技术支持:成都网站建设