Centos编译安装Apache 2.4.6笔记

之前服务器 Apache 版本一直是 2.2.x,鉴于 Centos 更新软件的惰性,我看直到 2014 年结束,apache 2.4 都不一定会出现在 Centos 中,我是不打算等了,编译安装吧。

升级前自行啃文档:Upgrading to 2.4 from 2.2。简单的说,如果沿用之前 2.2.x 的配置,Apache将无法启动。

Centos 编译安装 Apache 2.4 准备:

	yum groupinstall "Development tools"

之前服务器是 yum install httpd 安装的 Apache,所以可能解决了部分依赖关系,在我编译安装的过程中,只需要再格外 yum 两个 devel 包:

	yum install zlib-devel pcre-devel

从官方下载:

	wget http://mirror.bit.edu.cn/apache//httpd/httpd-2.4.6.tar.gz
	wget http://mirror.esocc.com/apache//apr/apr-1.4.8.tar.gz
	wget http://mirror.esocc.com/apache//apr/apr-util-1.5.2.tar.gz

解压缩:

	tar -xvf httpd-2.4.6.tar.gz
	tar -xvf apr-1.4.8.tar.gz
	tar -xvf apr-util-1.5.2.tar.gz

一点文件操作:

	mv apr-1.4.8 httpd-2.4.6/srclib/apr
	mv apr-util-1.5.2 httpd-2.4.6/srclib/apr-util
	cd httpd-2.4.4

编译命令:

	./configure --with-included-apr --enable-nonportable-atomics=yes --with-z

出奇的简单,因为默认就有 --enable-mods-shared=most ,模块化安装,以后自行到 httpd.conf 中决定是否开启模块,所以什么 --enable-deflate --enable-rewrite --enable-blablabla 等就完全不必要了。

默认安装的是 event mpm,如果要用 worker ,就需要--with-mpm=worker,或者干脆 --enable-mpms-shared=all,这样event、worker、prefork就会以模块化的方式安装,要用哪个就在 httpd.conf 里配置就好了。

编译完成后:

	make
	make install

安装完毕后, 所有的东西都在 /usr/local/apache2 这个目录下,最重要的当属 conf/httpd.conf ,自行配置吧。

加载模块上,我尽可能的做了精简,仅开启如下:

	必须:
	LoadModule authz_host_module modules/mod_authz_host.so
	LoadModule authz_core_module modules/mod_authz_core.so
	LoadModule userdir_module modules/mod_userdir.so
	LoadModule dir_module modules/mod_dir.so
	LoadModule mime_module modules/mod_mime.so
	设置超时:
	LoadModule reqtimeout_module modules/mod_reqtimeout.so
	以下三个都是为了配合 Google mod_pagespeed 才开启,不用可不开:
	LoadModule filter_module modules/mod_filter.so
	LoadModule deflate_module modules/mod_deflate.so
	LoadModule headers_module modules/mod_headers.so
	Apache 日志:
	LoadModule log_config_module modules/mod_log_config.so
	指定 Apache 用户和组:
	LoadModule unixd_module modules/mod_unixd.so
	phpMyAdmin 要用:
	LoadModule alias_module modules/mod_alias.so
	wordpress, joomla 要用:
	LoadModule rewrite_module modules/mod_rewrite.so

还有很多配置文件在 /usr/local/apache2/conf/extra 下面,在 httpd.conf 中可以选择是否加载,我加载的部分有:

	配置 timeout, keepalive 的
	httpd-default.conf
	配置 apache mpm 的
	httpd-mpm.conf
	这个很重要,性能优化基本上就靠这个文件了
	配置网站目录的
	httpd-userdir.conf
	配置虚拟主机的
	httpd-vhosts.conf

确定所有配置弄好后,就可以删除服务器上以前的 apache 了,至少我就是这么干的...:

	service httpd stop
	yum remove httpd

把新编译安装的 Apache 2.4.6 拷贝到位:

	cp /usr/local/apache2/bin/apachectl /etc/init.d/httpd

编辑 /etc/init.d/httpd 文件,在首行 #!/bin/sh 下面加入两行:

	# chkconfig: 35 85 15
	# description: Activates/Deactivates Apache 2.4.6

将 Apache 加入开机自动启动:

	chkconfig --add httpd
	chkconfig httpd on

最后一步,启动编译好的 Apache 2.4.6:

	service httpd start

Done.

Apache 是搞定了,但是之前通过 remi-test 源 yum 安装的 php 5.5 就不能用了,因为它依赖 httpd 包,卸载的时候一起卸掉了,编译 php 的事情,下篇再说。

简单 ab 测试过 apache 2.2 和 apache 2.4 之间的性能差异:

  • 静态内容,2.4完胜;
  • 动态内容,apache 2.4 和 2.2 之间没啥太大区别...

LAMP

Email: i at onepx dot com || QQ: ⑧九零三④幺 || 微信: onepxcom
©2019 一像素 蜀ICP备13026576号-2 技术支持:成都网站建设,Sponsor:生酮减肥